Video:Small site using BGP on two uplinks into an MPLS VPN network

From CT3

Jump to: navigation, search

The video describes the configuration of a redundant remote site design. The site has a single router that connects the site to the MPLS VPN network with two equal-speed uplinks. Both links are used in a load sharing setup. The router is using BGP as the PE-CE routing protocol.

Contents

Target audience

CCNA-level engineers who have to configure BGP on customer edge routers connected to MPLS VPN network.

Other prerequisite knowledge

Reference diagram

Image:BGPMPLSVPN_SingleRouterTwoUplinks_Diagram.png

Configuration commands

Command Explanation
router bgp Select the BGP routing process
neighbor ip-address remote-as as-number Configure a BGP neighbor
ip cef Enable Cisco Express Forwarding (CEF)
maximum-paths number Enable BGP load balancing

 

Router configurations

Initial configuration of the site router

hostname Site router
!
interface Loopback0
 ip address 10.0.1.5 255.255.255.255
!
interface FastEthernet0/0
 no shutdown
 ip address 10.2.3.1 255.255.255.0
!
interface Serial1/0
 no shutdown
 encapsulation ppp
 ip address 192.168.1.6 255.255.255.252
 no peer neighbor-route
!
router bgp 65101
 redistribute connected
 neighbor 192.168.1.5 remote-as 65000 

Final configuration of the site router

hostname Site router
!
ip cef
!
interface Loopback0
 ip address 10.0.1.5 255.255.255.255
!
interface FastEthernet0/0
 no shutdown
 ip address 10.2.3.1 255.255.255.0
!
interface FastEthernet0/1
 no shutdown
 ip address 192.168.2.2 255.255.255.240
!
interface Serial1/0
 no shutdown
 encapsulation ppp
 ip address 192.168.1.6 255.255.255.252
 no peer neighbor-route
!
router bgp 65101
 redistribute connected
 neighbor 192.168.1.5 remote-as 65000
 neighbor 192.168.2.1 remote-as 65000
 maximum-paths 4 
Personal tools

CT3

Main menu