Video:Simple BGP troubleshooting

From CT3

Jump to: navigation, search

The video describes simple BGP troubleshooting techniques, including session troubleshooting, BGP route origination troubleshooting and route propagation troubleshooting. These procedures are illustrated in a simple two-site MPLS/VPN-based network using BGP as the PE-CE routing protocol.

Contents

Target audience

CCNA-level engineers who have to configure BGP on customer edge routers connected to MPLS VPN network.

Other prerequisite knowledge

Reference diagram

Image:BGPMPLSVPN_Troubleshooting_Diagram.png

Monitoring commands

Command Explanation
show ip protocol Display the routing protocols running on a router
show ip bgp summary Display the state of BGP sessions
show ip route prefix Display a single IP prefix in the IP routing table
show ip bgp Display the contents of the BGP table
show ip bgp prefix Display a single IP prefix in the BGP table
show ip bgp regexp Display BGP routes where the AS-path matches the specified regular expression
show ip bgp neighbor advertised Display BGP routes advertised to the specified neighbor

 

BGP troubleshooting video

Router configurations

Configuration of CE-A

hostname Site-A
!
interface Loopback0
 ip address 10.0.1.5 255.255.255.255
!
interface FastEthernet0/0
 description Site A LAN
 ip address 10.2.3.1 255.255.255.0
!
interface Serial1/0
 description Link to PE router
 ip address 192.168.1.6 255.255.255.252
 encapsulation ppp
!
router bgp 65101
 bgp log-neighbor-changes
 neighbor 192.168.1.5 remote-as 65000
 redistribute connected
 no auto-summary 

Configuration of CE-B

hostname Site-B
!
interface Loopback0
 ip address 10.0.1.6 255.255.255.255
!
interface FastEthernet0/0
 description Site-B LAN
 ip address 10.2.1.1 255.255.255.0
!
interface Serial1/0
 description Link to PE router
 ip address 192.168.1.18 255.255.255.252
 encapsulation ppp
!
router bgp 65102
 bgp log-neighbor-changes
 redistribute connected
 neighbor 192.168.1.17 remote-as 65000
 no auto-summary 
Personal tools

CT3

Main menu