Video:Layer-3 switching in an MPLS VPN site

From CT3

Jump to: navigation, search

The video describes the configuration of a router connecting a small remote site with layer-3 switches to the MPLS VPN network. The L3 switches use OSPF and the CE router uses BGP to exchange routes with the MPLS VPN network.

Contents

Target audience

CCNA-level engineers who have to configure BGP on customer edge routers connected to MPLS VPN network.

Reference diagram

Image:L3SiteReferenceDiagram.png

Configuration commands

Command Explanation
router ospf id Select OSPF routing process configuration
network address mask area area Assign interfaces to OSPF areas
router bgp as-number Select BGP routing process configuration
redistribute ospf id match internal Redistribute internal OSPF routes into another routing protocol
redistribute bgp as-number subnets Redistribute BGP routes into OSPF
redistribute connected Redistribute directly connected IP subnets into BGP
default-information originate always Advertise default route into OSPF

Watch the video

Initial configurations

Configuration of the CE router

hostname CE-A
!
ip cef
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
 description LAN 1
 ip address 10.2.19.1 255.255.255.252
!
interface Serial1/0
 description Link to PE-C1(ROUTER)
 ip address 192.168.1.14 255.255.255.252
 encapsulation ppp
 no peer neighbor-route
!
router bgp 65100
 no synchronization
 bgp log-neighbor-changes
 redistribute connected
 neighbor 192.168.1.13 remote-as 65000
 no auto-summary
!
end 

Configuration of the L3 switch

hostname SW-A
!
ip cef
!
interface Loopback0
 ip address 10.0.1.3 255.255.255.255
!
interface Vlan101
 ip address 10.2.16.1 255.255.255.0
 ip ospf network point-to-point
!
interface Vlan102
 ip address 10.2.17.1 255.255.255.0
 ip ospf network point-to-point
!
interface Vlan103
 ip address 10.2.18.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 description Uplink
 ip address 10.2.19.2 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 22
!
end 

Final router configuration

Configuration of the CE router

hostname CE-A
!
ip cef
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
 description LAN 1
 ip address 10.2.19.1 255.255.255.252
!
interface Serial1/0
 description Link to PE-C1(ROUTER)
 ip address 192.168.1.14 255.255.255.252
 encapsulation ppp
 no peer neighbor-route
!
router ospf 1
 log-adjacency-changes
 network 10.2.19.1 0.0.0.0 area 22
 default-information originate always
!
router bgp 65100
 no synchronization
 bgp log-neighbor-changes
 redistribute connected
 redistribute ospf 1 match internal
 neighbor 192.168.1.13 remote-as 65000
 no auto-summary
!
end 
Personal tools

CT3

Main menu