Unnumbered Ethernet VLAN interfaces

From CT3

Jump to: navigation, search

By Ivan Pepelnjak

IOS releases 12.3T, 12.4, 12.2SXE, 12.2SB and 12.2SR support unnumbered Ethernet VLAN interfaces. This feature can help you save IP address space as you’re replacing point-to-point WAN links between the routers with Carrier Ethernet links between layer-3 switches (traditionally you have to spend a /30 subnet on each point-to-point layer-3 VLAN link).

Introduction of unnumbered VLAN interfaces reduces IP address usage
The merits of using unnumbered router-to-router links are debatable. It’s not advisable, though, to use private addresses on these links if you’re operating a public network.

Contents

Configuration

The unnumbered Ethernet interface configuration is simple: you’re using the well-known ip unnumbered interface configuration command which can be applied on a VLAN subinterface like the following configuration example:

Sample unnumbered VLAN interface configuration

interface Loopback0
 ip address 10.2.0.1 255.255.255.255
 ip router isis 
!
interface FastEthernet0/1
 no ip address
!
interface FastEthernet0/1.1
 encapsulation dot1Q 100
 ip unnumbered Loopback0 

Limitations

The feature has several limitations:

  • You can use the ip unnumbered command only on Ethernet subinterfaces, not on the main interface. To use it on a non-VLAN link, you have to create a subinterface with dot1q native encapsulation:

Unnumbered non-VLAN interface

interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 1 native
 ip unnumbered Loopback0 
  • OSPF cannot be run as the routing protocol over the unnumbered Ethernet interfaces, it does not recognize the “unnumbered” interface status, as illustrated in the following example:

OSPF refuses to start on an unnumbered VLAN interface

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fa0/1.1
R1(config-subif)#ip ospf 1 area 0
R1(config-subif)#
*Jun 21 10:42:34.189: %OSPF-4-NO_IPADDRESS_ON_INT: No IP address for interface FastEthernet0/1.1
R1(config-subif)# 

All other interior routing protocols (EIGRP, RIP and IS-IS) can be used over unnumbered VLAN interfaces, the following printout contains a sample IS-IS configuration:

Running IS-IS over an unnumbered VLAN interface

interface Loopback0
 ip address 10.2.0.1 255.255.255.255
 ip router isis 
!
interface FastEthernet0/1
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 1 native
 ip unnumbered Loopback0
 ip router isis 
 isis network point-to-point 
!
router isis
 net 49.0001.0000.0000.0001.00 

References

Sample configurations

These printouts contain the configurations of routers used in the test. The routers were running IOS release 12.4(22)T.

Configuration of R1

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
no aaa new-model
ip source-route
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
interface Loopback0
 ip address 10.2.0.1 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 10.2.1.1 255.255.255.0
 duplex half
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 1 native
 ip unnumbered Loopback0
 ip router isis 
 isis network point-to-point 
 isis csnp-interval 10
!
router isis
 net 49.0001.0000.0000.0001.00
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
 shutdown 
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 transport preferred none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 transport preferred none
!
ntp logging
end 

Configuration of R2

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
no aaa new-model
ip source-route
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
interface Loopback0
 ip address 10.2.0.2 255.255.255.255
 ip router isis 
!
!
interface FastEthernet0/0
 ip address 10.2.2.1 255.255.255.0
 duplex half
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 1 native
 ip unnumbered Loopback0
 ip router isis 
 isis network point-to-point 
 isis csnp-interval 10
!
router isis
 net 49.0001.0000.0000.0002.00
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 transport preferred none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 transport preferred none
!
ntp logging
end 
Personal tools

CT3

Main menu