Run RIP on all interfaces

From CT3

Jump to: navigation, search

By Ivan Pepelnjak

According to Cisco IOS documentation, the network RIP router configuration command accepts a major network number (without subnets) as its parameter. If you want to run RIP on multiple major networks (a common scenario in enterprise networks using private IP address space in the 192.168.0.0/16 address range), you have to list all major networks attached to the router in the RIP routing process.

For example, if you want to run RIP on all interfaces of the router with the following interface configuration …

interface Loopback0
 ip address 10.0.1.4 255.255.255.255
!
interface Serial1/2
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1/3
 ip address 172.16.0.1 255.255.255.252

… you have to use the following RIP configuration according to Cisco IOS documentation:

router rip
 version 2
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
You can verify the list of interfaces used by the RIP routing process with the show ip protocols command.

The network RIP router configuration command also accepts the default network (0.0.0.0) as its parameter, causing RIP to run on all interfaces in a router. Using this undocumented feature, the configuration from the previous printout can be reduced to the following one:

router rip
 version 2
 network 0.0.0.0
 no auto-summary

The show ip protocols command verifies that RIP still uses all available interfaces:

R1#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 10 seconds, next due in 8 seconds
  Invalid after 30 seconds, hold down 20, flushed after 40
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial1/2             2     2
    Serial1/3             2     2
    Loopback0             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    0.0.0.0

Additional Resources  

Interconnecting Interconnecting Cisco Network Devices Part 2 (ICND2) course:

Building Scalable Cisco Internetworks (BSCI) course:

Other links

Personal tools

CT3

Main menu