RIP interface summaries cause routing loops

From CT3

Jump to: navigation, search

By Ivan Pepelnjak

When a RIP summary address is configured on an interface with the ip summary-address rip network mask configuration command, a corresponding summary route pointing to Null 0 is not installed in the IP routing table, resulting in routing loops in networks where the summarization is improperly configured.

In the network shown in the following diagram, the RIP summary address is configured only on a single core-to-access link:

Figure 1: Simple RIP network with incorrect summary-address design
hostname A1
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
 description LAN 0 (A1-A2)
 ip address 10.2.1.1 255.255.255.0
!
interface Serial1/0
 description Link to R1(ROUTER) S1/0
 ip address 10.0.7.9 255.255.255.252
 ip summary-address rip 10.0.1.0 255.255.255.0
!
router rip
 version 2
 network 0.0.0.0

The summary prefix 10.0.1.0/24 advertised from A1 to R1 is propagated to R2 and A2, which accepts it, as there is no corresponding summary address configured on the A2-R2 link (see the inbound processing rules section of the RIP route database document) and propagates it back to A1.

A2#show ip route rip
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
R       10.0.7.8/30 [120/1] via 10.2.1.1, 00:00:01, FastEthernet0/0
R       10.0.1.1/32 [120/1] via 10.2.1.1, 00:00:01, FastEthernet0/0
R       10.0.1.0/24 [120/3] via 10.0.7.14, 00:00:04, Serial1/0
R       10.0.1.5/32 [120/1] via 10.0.7.14, 00:00:04, Serial1/0
R       10.0.1.4/32 [120/2] via 10.2.1.1, 00:00:01, FastEthernet0/0
                    [120/2] via 10.0.7.14, 00:00:04, Serial1/0
R       10.0.7.20/30 [120/1] via 10.0.7.14, 00:00:04, Serial1/0

Since the summary prefix is received through the Ethernet interface, A1 accepts it and the routing loop is complete.

A1#show ip route rip
      10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
R        10.0.1.0/24 [120/4] via 10.2.1.2, 00:00:02, FastEthernet0/0
R        10.0.1.2/32 [120/1] via 10.2.1.2, 00:00:02, FastEthernet0/0
R        10.0.1.4/32 [120/1] via 10.0.7.10, 00:00:04, Serial1/0
R        10.0.1.5/32 [120/2] via 10.2.1.2, 00:00:02, FastEthernet0/0
                     [120/2] via 10.0.7.10, 00:00:04, Serial1/0
R        10.0.7.12/30 [120/1] via 10.2.1.2, 00:00:02, FastEthernet0/0
R        10.0.7.20/30 [120/1] via 10.0.7.10, 00:00:04, Serial1/0

If you perform a trace from any of the routers to an unreachable destination in the summary address range, the packet will loop around the network continuously.

A1#trace 10.0.1.18

Type escape sequence to abort.
Tracing the route to 10.0.1.18

  1 10.2.1.2 4 msec 4 msec 4 msec
  2 10.0.7.14 16 msec 4 msec 4 msec
  3 10.0.7.22 4 msec 8 msec 8 msec
  4 10.0.7.9 16 msec 12 msec 8 msec
  5 10.2.1.2 20 msec 12 msec 12 msec
  6 10.0.7.14 20 msec 24 msec 20 msec
  7 10.0.7.22 28 msec 32 msec 28 msec
  8 10.0.7.9 24 msec 24 msec 16 msec
  9 10.2.1.2 28 msec 40 msec 20 msec
 10 10.0.7.14 28 msec 24 msec 32 msec
 11 10.0.7.22 28 msec 32 msec 36 msec
 12 10.0.7.9 36 msec 60 msec 32 msec
 13 10.2.1.2 40 msec 36 msec 36 msec
 14 10.0.7.14 40 msec 40 msec 36 msec

To fix the routing loop, you have to configure a summary address on the A2-R2 link. The summarization prefix has to be identical to the one configured on the A1-R1 link.

Figure 2: Valid design – summary address is configured on all core-access links

After the ip summary-address rip 10.0.1.0 255.255.255.0 has been configured, A2 ignores the 10.0.1.0/24 prefix received from R2, breaking the routing loop.

A2#show ip route rip
     10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
R       10.0.7.8/30 [120/1] via 10.2.1.1, 00:00:05, FastEthernet0/0
R       10.0.1.1/32 [120/1] via 10.2.1.1, 00:00:05, FastEthernet0/0
R       10.0.1.5/32 [120/1] via 10.0.7.14, 00:00:07, Serial1/0
R       10.0.1.4/32 [120/2] via 10.2.1.1, 00:00:05, FastEthernet0/0
                    [120/2] via 10.0.7.14, 00:00:07, Serial1/0
R       10.0.7.20/30 [120/1] via 10.0.7.14, 00:00:07, Serial1/0

Additional Resources  

Interconnecting Interconnecting Cisco Network Devices Part 2 (ICND2) course:

Building Scalable Cisco Internetworks (BSCI) course:

Other links

Personal tools

CT3

Main menu