Missing routes when running IS-IS over Frame Relay

From CT3

Jump to: navigation, search

By Ivan Pepelnjak

Symptom When running IS-IS over partially-meshed multi-access Frame Relay subnet, some routes from the remote IS-IS routers are not inserted in the IP routing table even though the adjacencies have been established and the LSPs are received from the remote routers.
Potential
diagnosis
A router that does not have direct connectivity to all other routers attached to the Frame Relay subnet was elected the Designated Intermediate System (DIS; equivalent to Designated Router).
Verification Check the DIS election with the show clns interface command executed on the hub router.
Solution Increase the DIS election priority of the hub router with the isis priority interface configuration command. See IS-IS on multi-access partially-meshed Frame Relay interface and IS-IS on partially-meshed Frame Relay subnet: sample configuration for more details.

Contents

In-depth description

The router functioning as DIS on a partially-meshed WAN subnet (or any other IP subnet with limited connectivity between adjacent routers) must have direct connectivity with all other routers connected to the same subnet. The DIS includes only its neighbors in the network LSP it advertises; if one of the routers in the same subnet is not a neighbor of DIS, it is not listed in the network LSP, resulting in broken topology graph.

For example, assume all routers in the Figure 1 have the same DIS election priority (see the Sample configurations section for detailed router configurations).

Figure 1: Sample network diagram

When the routers have equal priority, the router with the highest CLNS address (S3 in the sample network) becomes DIS and advertises network LSP connected to its neighbors. Due to limited connectivity, multiple routers in the same subnet can become DIS, resulting in multiple network LSPs for the same IP subnet residing in the IS-IS topology database. In the network shown in Figure 1, S3 and S1 become DIS (S3 because it has higher NET than any other router in the same subnet and S1 because it has higher NET than the hub router), resulting in the network topology displayed in Figure 2.

Figure 2: IS-IS topology database

As there is no link from the hub router to S1 (the link between S1.02 and HUB is unidirectional), the hub router will not insert routes advertised by S1 into its routing table:

HUB#show ip route isis
     10.0.0.0/32 is subnetted, 3 subnets
i L1    10.0.1.3 [115/20] via 192.168.0.12, Serial1/0
i L1    10.0.1.4 [115/20] via 192.168.0.13, Serial1/0

Verification

Use the show clns interface on the hub router. Verify that the hub router acts as DIS for the WAN subnet. In the sample network, the show clns interface on the hub router displays S3 as DIS, confirming the diagnosis.

HUB#show clns interface serial 1/0
Serial1/0 is up, line protocol is up
  Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 46 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x1, local circuit ID 0x2
    Level-1 Metric: 10, Priority: 64, Circuit ID: S3.02
    DR ID: S3.02
    Level-1 IPv6 Metric: 10
    Number of active level-1 adjacencies: 3
    Level-2 Metric: 10, Priority: 64, Circuit ID: S3.02
    DR ID: S3.02
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 3
    Next IS-IS LAN Level-1 Hello in 2 seconds
    Next IS-IS LAN Level-2 Hello in 3 seconds

Solution

Set the IS-IS interface priority on the non-hub routers (routers that are not directly connected to all other routers in the same subnet) to zero. See the Corrected configurations section for a working example. After the IS-IS interface priority has been configured on the WAN interface, the hub router is elected as the DIS as displayed in the following printout.

HUB#show clns interface serial 1/0
Serial1/0 is up, line protocol is up
  Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 28 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x1, local circuit ID 0x2
    Level-1 Metric: 10, Priority: 127, Circuit ID: HUB.02
    DR ID: HUB.02
    Level-1 IPv6 Metric: 10
    Number of active level-1 adjacencies: 3
    Level-2 Metric: 10, Priority: 127, Circuit ID: HUB.02
    DR ID: HUB.02
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 3
    Next IS-IS LAN Level-1 Hello in 1 seconds
    Next IS-IS LAN Level-2 Hello in 340 milliseconds

Using the correct IS-IS topology, every router in the network installs all routes advertised by IS-IS:

HUB#show ip route isis
     10.0.0.0/32 is subnetted, 4 subnets
i L1    10.0.1.3 [115/20] via 192.168.0.12, Serial1/0
i L1    10.0.1.2 [115/20] via 192.168.0.11, Serial1/0
i L1    10.0.1.4 [115/20] via 192.168.0.13, Serial1/0
S3#show ip route isis
     10.0.0.0/32 is subnetted, 4 subnets
i L1    10.0.1.3 [115/20] via 192.168.0.12, Serial1/0
i L2    10.0.1.2 [115/30] via 192.168.0.1, Serial1/0
i L1    10.0.1.1 [115/20] via 192.168.0.1, Serial1/0

Sample configurations

Hub initial configuration

hostname HUB
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 1
 ip address 192.168.0.1 255.255.255.0
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 100 broadcast
 frame-relay map clns 101 broadcast
 frame-relay map clns 102 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.0000.0000.0001.00
 log-adjacency-changes 

S1 initial configuration

hostname S1
!
interface Loopback0
 ip address 10.0.1.2 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 2
 ip address 192.168.0.11 255.255.255.0
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 100 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.0000.0000.0011.00
 log-adjacency-changes 

S2 initial configuration

hostname S2
!
interface Loopback0
 ip address 10.0.1.3 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 3
 ip address 192.168.0.12 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map clns 105 broadcast
 frame-relay map clns 101 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.0000.0000.0012.00
 log-adjacency-changes 

S3 initial configuration

hostname S3
!
interface Loopback0
 ip address 10.0.1.4 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 4
 ip address 192.168.0.13 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map clns 105 broadcast
 frame-relay map clns 102 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.0000.0000.0013.00
 log-adjacency-changes 

Corrected configurations

Hub final configuration

hostname HUB
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 1
 ip address 192.168.0.1 255.255.255.0
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 100 broadcast
 frame-relay map clns 101 broadcast
 frame-relay map clns 102 broadcast
 frame-relay lmi-type ansi
 isis priority 127
!
router isis
 net 49.0001.0000.0000.0001.00
 log-adjacency-changes 

S1 final configuration

hostname S1
!
interface Loopback0
 ip address 10.0.1.2 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 2
 ip address 192.168.0.11 255.255.255.0
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 100 broadcast
 frame-relay lmi-type ansi
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0011.00
 log-adjacency-changes 

S2 final configuration

hostname S2
!
interface Loopback0
 ip address 10.0.1.3 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 3
 ip address 192.168.0.12 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map clns 105 broadcast
 frame-relay map clns 101 broadcast
 frame-relay lmi-type ansi
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0012.00
 log-adjacency-changes 

S3 final configuration

hostname S3
!
interface Loopback0
 ip address 10.0.1.4 255.255.255.255
 ip router isis
!
interface Serial1/0
 description Link to FR(FRSW) 4
 ip address 192.168.0.13 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map clns 105 broadcast
 frame-relay map clns 102 broadcast
 frame-relay lmi-type ansi
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0013.00
 log-adjacency-changes 

Additional Resources  

Configuring Configuring Cisco Routers for Integrated IS-IS (CISIS) course:

Building Scalable Cisco Internetworks (BSCI) course:

Other links:

Did you know?

  • NIL developed the first commercially available advanced technical training covering Cisco IOS implementation of IS-IS.
  • This course was for several years the only course available to Cisco's internal audiences and its Service Provider customers in Europe.
  • The IS-IS course developed by NIL later became part of Cisco's Service Provider training curriculum.
  • NIL's experts have helped several large Service Providers design and deploy IS-IS networks.
Personal tools

CT3

Main menu