IS-IS on partially-meshed Frame Relay subnet: sample configuration

From CT3

Jump to: navigation, search

By Ivan Pepelnjak

This article contains sample IS-IS configuration on partially-meshed Frame Relay network displayed in . The configuration does not use subinterfaces but relies on guidelines described in the IS-IS on multi-access partially-meshed Frame Relay interface article.

Figure 1: Sample network diagram

Contents

Initial router configurations

The following printouts contain initial router configurations for all four routers connected to the Frame Relay network:

Hub router: initial configuration

hostname HUB
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255 
!
interface Serial1/0
 ip address 192.168.0.1 255.255.255.0 
 encapsulation frame-relay 

S1: initial configuration

hostname S1
!
interface Loopback0
 ip address 10.0.1.2 255.255.255.255 
!
interface Serial1/0
 ip address 192.168.0.11 255.255.255.0 
 encapsulation frame-relay 

S2: initial configuration

hostname S2
!
 interface Loopback0 
 ip address 10.0.1.3 255.255.255.255 
!
interface Serial1/0
 ip address 192.168.0.12 255.255.255.0 
 encapsulation frame-relay 

S3: initial configuration

hostname S3
!
interface Loopback0
 ip address 10.0.1.4 255.255.255.255 
!
interface Serial1/0
 ip address 192.168.0.13 255.255.255.0 
 encapsulation frame-relay 
 frame-relay lmi-type ansi 

The Frame Relay virtual circuits configured in the WAN network are documented in the following table:

Router#1 DLCI Router #2 DLCI
Hub 100 S1 100
Hub 101 S2 101
Hub 102 S3 102

IS-IS configuration

To configure IS-IS running on a partially-meshed Frame Relay subnet, perform the following steps:

  1. Configure the IS-IS routing process with the router isis configuration command. To simplify addressing, we’ll configure all routers in area 49.0001 (using the net router configuration command) and the system ID will match the last octet of the IP address configured on the serial interface.
  2. Configure IS-IS priority on the serial interface with the isis priority interface configuration command. The hub router should have high priority (127 is the maximum value) and the spoke routers should have the priority set to zero to prevent them from becoming eligible for the DIS role.
  3. Enable IS-IS on the loopback and WAN interfaces with the ip router isis interface configuration command.
  4. Configure frame relay DLCIs for CLNS operation with the frame-relay map clns number broadcast interface configuration command.

The IS-IS configuration of all four routers is displayed in the following printouts:

Hub router: IS-IS configuration

hostname HUB
!
interface Loopback0
 ip router isis  
!
interface Serial1/0
 ip router isis  
 frame-relay map clns 102 broadcast 
 frame-relay map clns 101 broadcast 
 frame-relay map clns 100 broadcast 
 isis priority 127
!
router isis
 net 49.0001.0000.0000.0001.00 
 log-adjacency-changes 

S1: IS-IS configuration

hostname S1
!
interface Loopback0
 ip router isis  
!
interface Serial1/0
 ip router isis  
 frame-relay map clns 100 broadcast 
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0011.00 
 log-adjacency-changes 

S2: IS-IS configuration

hostname S2
!
interface Loopback0
 ip router isis  
!
interface Serial1/0
 ip router isis  
 frame-relay map clns 101 broadcast 
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0012.00 
 log-adjacency-changes 

S3: IS-IS configuration

hostname S3
!
interface Loopback0
 ip router isis  
!
interface Serial1/0
 ip router isis  
 frame-relay map clns 102 broadcast 
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0013.00 
 log-adjacency-changes 

Verification

After configuring IS-IS on Frame Relay, you shall verify:

  • Frame Relay maps (optional)
  • IS-IS adjacencies
  • DIS election
  • Generation of network LSP
  • IP routing tables (optional)

Frame Relay map verification

Use the show frame-relay map command to display CLNS frame-relay maps. Check the broadcast option on every CLNS map.

HUB#show frame-relay map interface Serial1/0 | section CLNS
Serial1/0 (up): CLNS dlci 1dyddyd00(0x64,0x1840), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): CLNS dlci 101(0x65,0x1850), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): CLNS dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

Unless you’ve disabled inverse ARP, the IP frame relay maps will be created automatically for every operational DLCI available on the Frame Relay interface. These maps help you verify that you’ve configured all DLCIs available on the interface (if a DLCI has an IP mapping but no CLNS mapping, you’ve forgot to configure the DLCI for CLNS operation).

HUB#show frame-relay map interface Serial1/0
Serial1/0 (up): ip 192.168.0.11 dlci 100(0x64,0x1840), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): CLNS dlci 100(0x64,0x1840), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.0.12 dlci 101(0x65,0x1850), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): CLNS dlci 101(0x65,0x1850), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.0.13 dlci 102(0x66,0x1860), dynamic,
              broadcast,, status defined, active
Serial1/0 (up): CLNS dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

IS-IS adjacencies verification

Verify the IS-IS adjacencies with the show isis neighbors command. You might want to use output filters to limit the display to one interface. When the routers are configured as L1/L2 routers (the default setting), you might see both L1 and L2 adjacencies between a pair of routers. You can use output filters to display only L1 or L2 adjacencies:

HUB#show isis neighbors | inc L2 +Se1/0
S2             L2   Se1/0       192.168.0.12    UP    23       HUB.02
S3             L2   Se1/0       192.168.0.13    UP    27       HUB.02
S1             L2   Se1/0       192.168.0.11    UP    26       HUB.02

DIS election verification

Use the show clns interface to verify the DIS election priorities and the elected DIS. The hub router should have high priority and the spoke routers should have the priority set to zero. The hub router should become DIS.

HUB#show clns interface serial1/0
Serial1/0 is up, line protocol is up
  Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 13 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x1, local circuit ID 0x2
    Level-1 Metric: 10, Priority: 127, Circuit ID: HUB.02
    DR ID: HUB.02
    Level-1 IPv6 Metric: 10
    Number of active level-1 adjacencies: 3
    Level-2 Metric: 10, Priority: 127, Circuit ID: HUB.02
    DR ID: HUB.02
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 3
    Next IS-IS LAN Level-1 Hello in 1 seconds
    Next IS-IS LAN Level-2 Hello in 983 milliseconds

You might want to use output filters to minimize the amount of information generated by the show clns interface command:

S3#show clns interface Serial1/0 | include ID
    Interface number 0x1, local circuit ID 0x2
    Level-1 Metric: 10, Priority: 0, Circuit ID: HUB.02
    DR ID: HUB.02
    Level-2 Metric: 10, Priority: 0, Circuit ID: HUB.02
    DR ID: HUB.02

Network LSP verification

The show clns interface command displays the network LSP (Circuit ID) associated with the multi-access WAN interface. Use the show isis database command to display the contents of the network LSP. The network LSP should contain links to all routers attached to the Frame Relay network:

S3#show isis database level-2 HUB.02-00 detail
IS-IS Level-2 LSP HUB.02-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
HUB.02-00             0x00000005   0x9EE9        759               0/0/0
  Metric: 0          IS HUB.00
  Metric: 0          IS S2.00
  Metric: 0          IS S3.00
  Metric: 0          IS S1.00

IP routing table verification

If the network LSP has been originated by (one of) the hub router(s), the IP routing table should reflect the actual topology of the Frame Relay network (IS-IS automatically computes correct next-hop addresses). It’s still advisable, however, to verify the state of the IP routing table with the show ip route isis command and check that:

  • All the expected IS-IS routes have been inserted into the IP routing table;
  • IS-IS computed correct next-hop addresses.
S3#show ip route isis | section Serial1/0
     10.0.0.0/32 is subnetted, 4 subnets
i L2    10.0.1.3 [115/30] via 192.168.0.1, Serial1/0
i L2    10.0.1.2 [115/30] via 192.168.0.1, Serial1/0
i L1    10.0.1.1 [115/20] via 192.168.0.1, Serial1/0


HUB#show ip route isis | section Serial1/0
     10.0.0.0/32 is subnetted, 4 subnets
i L1    10.0.1.3 [115/20] via 192.168.0.12, Serial1/0
i L1    10.0.1.2 [115/20] via 192.168.0.11, Serial1/0
i L1    10.0.1.4 [115/20] via 192.168.0.13, Serial1/0

Final router configurations

The following printouts contain the final (abridged) configurations of all four routers:

Hub router: abridged final configuration

hostname HUB
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255 
 ip router isis  
!
interface Serial1/0
 ip address 192.168.0.1 255.255.255.0 
 ip router isis  
 encapsulation frame-relay 
 frame-relay map clns 102 broadcast 
 frame-relay map clns 101 broadcast 
 frame-relay map clns 100 broadcast 
 isis priority 127 
!
router isis
 net 49.0001.0000.0000.0001.00 
 log-adjacency-changes 

S1: abridged final configuration

hostname S1
!
interface Loopback0
 ip address 10.0.1.2 255.255.255.255 
 ip router isis  
!
interface Serial1/0
 ip address 192.168.0.11 255.255.255.0 
 ip router isis  
 encapsulation frame-relay 
 frame-relay map clns 100 broadcast 
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0011.00 
 log-adjacency-changes 

S2: abridged final configuration

hostname S2
!
interface Loopback0
 ip address 10.0.1.3 255.255.255.255 
 ip router isis  
!
interface Serial1/0
 ip address 192.168.0.12 255.255.255.0 
 ip router isis  
 encapsulation frame-relay 
 frame-relay map clns 101 broadcast 
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0012.00 
 log-adjacency-changes 

S3: abridged final configuration

hostname S3
!
interface Loopback0
 ip address 10.0.1.4 255.255.255.255 
 ip router isis  
!
interface Serial1/0
 ip address 192.168.0.13 255.255.255.0 
 ip router isis  
 encapsulation frame-relay 
 frame-relay map clns 102 broadcast 
 isis priority 0
!
router isis
 net 49.0001.0000.0000.0013.00 
 log-adjacency-changes 

Additional Resources  

Configuring Configuring Cisco Routers for Integrated IS-IS (CISIS) course:

Building Scalable Cisco Internetworks (BSCI) course:

Other links:

Did you know?

  • NIL developed the first commercially available advanced technical training covering Cisco IOS implementation of IS-IS.
  • This course was for several years the only course available to Cisco's internal audiences and its Service Provider customers in Europe.
  • The IS-IS course developed by NIL later became part of Cisco's Service Provider training curriculum.
  • NIL's experts have helped several large Service Providers design and deploy IS-IS networks.
Personal tools

CT3

Main menu